can disable function+left click= right click?

  • Started playing the beta this weekend on my 27" iMac this weekend and everything has been running relatively smooth, until I decide to play through the game with some buddies and communicate over ventrilo.

    My normal ventrilo push-to-talk button is the Function key (has been for years, at the bottom corner of my keyboard).
    This causes a major problem with D3 as Function + Left Click = Right Click, and after searching for awhile I can't seem to find a way to fix this.

    I obviously use a normal mouse for gaming.... as (no offense) I don't see why you wouldn't...

    I have played with both the "Disable OS Keyboard Shortcuts" on and off and neither option seems to help.

    Please tell me I am just missing something completely obvious and that there is a way to fix this. I would love it if buttons like function and command (which currently seems to be the same as "control" in game, which is kinda annoying too) would simply do nothing while playing.

    Sorry if this is the wrong forum (figured it was the safest place to avoid flaming), and if for some reason I need to post my Mac's specs I can.
  • This was changed for WoW Beta but I am not sure about D3. I'll touch base with the team to see what the case is.
  • This change is being discussed for Diablo III as well. I'll let you know when I got something more solid to grasp on.
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

    I'm not big on boasting, but you might have to take a victory lap.