Updated video drivers, now beta won't work

  • This was working before but now I get an error. Just updated yesterday. The error when I go to play is:

    "We have detected that your video driver is not compatible with Diablo III Beta"

    Operating System: Windows 7 Service Pack 1
    Video Card: AMD Radeon HD 6670

    Help!

    PS: (I have re-booted the machine already also)
  • You can all post your dxdiag info if you like but even if it's just a matter of using an outdated video driver, it's not going to let you play as the Beta has already ended.

    ____________________________________________________________________
    Support Information Administrator
  • Siggs,

    Try reverting to 12.2 and see if you get the same message. 12.4 wasn't having much luck with the D3 Beta.

    http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista64.aspx

    ____________________________________________________________________
    Support Information Administrator
  • Siggs,

    Thought it might. I did a little checking after I last posted and apparently, the 12.4 release is having enough issues right now that we're going to post that warning you saw if they're detected in use. The best solution, again for now, is to revert to a slightly older release. This is subject to change at any time, but for now, it looks like it's going to continue on into release.

    Any updates to this will of course be posted in this forum.

    ____________________________________________________________________
    Support Information Administrator
  • Mavic,

    Same issue. Your Catalyst 12.4 drivers aren't supported. You'll need to revert to an earlier version.

    12.2 can be found here: http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista64.aspx

    ____________________________________________________________________
    Support Information Administrator
  • AngryLawyer,

    We aren't saying they're "too up to date", we're saying they're not supported. A compatibility issue surfaced with them severe enough to warrant this decision.

    ____________________________________________________________________
    Support Information Administrator